PDA

View Full Version : network drive not accessible throught task planner



alexandre
23.07.2020, 01:29 PM
hi,
i created a simple script to start a slideshow:
"C:\Program Files\IrfanView\i_view64.exe" /slideshow=Z:\pictures\*.jpg /reloadonloop /fs /bf

when i double click on it, it works!
Z: is accessible from explorer.

If i put this script in task planner, i receive an error from irfan:
No files in the input list!

i click "ok" on the error message, irfan is still open, then i click on "open" and i don't see the network drive Z:
So i close irfan, relaunch it by the shortcut, "open", and here, i can see the network drive Z:

The network drive disappear when the script is launch throught the task planner.

I tried:
use unc path in my script: "C:\Program Files\IrfanView\i_view64.exe" /slideshow=\\nas01\folder\pictures\*.jpg /reloadonloop /fs /bf
unistall with revo uninstaller, reinstall, install plugins saw this: https://irfanview-forum.de/showthread.php?t=12268

Any idea ?

thanks

cwb3106
26.07.2020, 04:06 PM
FWIW, your script worked for me using i_view32. Perhaps the problem is with the 64-bit version.

You might try changing the script to navigate to the mapped drive first and defaulting the directory on the IrfanView command line. Something like:

PUSHD "Z:\pictures"
"C:\Program Files\IrfanView\i_view64.exe" /slideshow=*.jpg /reloadonloop /fs /bf
POPD