PDA

View Full Version : thumbnails.html bleibt leer



ich
03.08.2008, 09:01 PM
Hallo,

ich wollte mal eben wieder auf die schnelle so eine Webgallerie erstellen aber die Thumnails.html fürht die einzelnen Bilder garnicht auf nach dem speichern als html. Die htmls der Einzelbilder werden erstellt.

Ich habs dann auch mit den orignal template versucht und es geht genauso wenig. Hab aber seit dem letzten erfolgreichen erstellen auch nix verändert. Was könnte ich falsch machen?


<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html>
<head>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">
<meta name="GENERATOR" content="IrfanView">

<title>#TITLE#</title>
<style>body {font-family:Verdana;}</style>
</head>

<body bgcolor="#BGCOLOR#">

<center>
<h4>#TITLE#</h4>
<hr>

<TABLE>

#IMAGE_BEGIN#
<TD ALIGN=CENTER VALIGN=BOTTOM><FONT face="Verdana, Arial, Helvetica, Sans-Serif" size="-2">
<A HREF="#LINK#" target="#TARGET#" style="text-decoration:none"><IMG SRC=#THUMB# BORDER="0" ALT="#ALT_TXT#">
<div style="text-align: #TXT_ALIGN#">#IMAGE_TEXT#</div></A></FONT></TD>
#IMAGE_END#

</TABLE>

<hr>
<h4><small><small><A HREF="http://www.irfanview.com" style="text-decoration:none">Created by IrfanView</A></small></small></h4>
</center>
</body>
</html>

Foxy
04.08.2008, 12:00 PM
Was Du falsch machen könntest, das weiß ich nicht (am besten vielleicht überhaupt nichts?); was Du aktuell falsch machst hingegen schon. Doch den Flachs beiseite.

Die von Dir zum Einsatz gebrachte Vorlagendatei ist an entscheidender Stelle fehlerhaft. So muß es statt #IMAGE_BEGIN# %IMAGE_BEGIN% und statt #IMAGE_END# %IMAGE_END% heißen. Dann füllt sich die spätere Indexdatei auch wieder mit dem gewünschten Inhalt.


(Im Anhang beigefügt der Original-Vorlagensatz.)

ich
04.08.2008, 06:22 PM
Ja super, so funktioniert das. :)

Kann mir zwar nicht erklären warum es auf einmal falsch war. Höchtens das nach einem Software Update % statt # genommen wurde und die templates nicht geupdatet wurden. Merkwürdig.