PDA

View Full Version : Fixed v4.23/v4.22 Fehlermeldung beim "Speichern unter..." dem PDF-Format



Frank
28.12.2008, 08:15 PM
Bezüglich der 'Fehlermeldung beim "Speichern unter..." dem PDF-Format' habe ich 'mal versucht, systematisch vorzugehen!
Es existieren im Forum z.B. diese Fehlerberichte:
- Error Message When Saving as PDF (http://en.irfanview-forum.de/vb/showthread.php?t=3432)
- jpg in pdf "PDF Fehler beim Speichern" (http://en.irfanview-forum.de/vb/showthread.php?t=3074)
- PDF save error (http://en.irfanview-forum.de/vb/showthread.php?t=2808)
- save as or convert to PDF, having trouble (http://en.irfanview-forum.de/vb/showthread.php?t=2780)

Und da es seit dem Versionswechsel von IrfanView (http://www.irfanview.com/) V4.20 auf V4.22 möglich sein soll, zum Lesen
des EPS (http://de.wikipedia.org/wiki/Encapsulated_PostScript)-, PS (http://de.wikipedia.org/wiki/PostScript)- und PDF (http://de.wikipedia.org/wiki/Portable_Document_Format)-Formates GPL Ghostscript (http://sourceforge.net/project/showfiles.php?group_id=1897&package_id=108733) (anstelle von AFPL Ghostscript (http://sourceforge.net/project/showfiles.php?group_id=1897&package_id=1845)) zu verwenden
(siehe: list of supported file formats (http://www.irfanview.com/main_formats.htm)), habe ich auf meinem PC den entsprechenden Wechsel beim installiertem Ghostscript (http://sourceforge.net/projects/ghostscript/) vollzogen!
Denn zum Schreiben des PDF-Formats ist bei IrfanView (http://www.irfanview.com/) das ImPDF (http://www.comsquare.ch/index.php?option=com_content&task=view&id=20&Itemid=39)-Plugin verantwortlich!

Deshalb auch noch 'mal der Hinweis auf den älteren Beitrag Ghostscript Plugin (http://en.irfanview-forum.de/vb/showthread.php?t=2349),
in dem Zusammenhänge und Erkenntnisse zu den Funktionen einzelner Plugins beschrieben sind!

Hier meine Testergebnisse:
- mit installiertem AFPL Ghostscript (http://sourceforge.net/project/showfiles.php?group_id=1897&package_id=1845) V8.54:

IrfanView (http://www.irfanview.com/) V4.20 + ImPDF (http://www.comsquare.ch/index.php?option=com_content&task=view&id=20&Itemid=39) V0.40 + Postscript.dll V4.20 = Keine Fehlermeldung!
IrfanView (http://www.irfanview.com/) V4.20 + ImPDF (http://www.comsquare.ch/index.php?option=com_content&task=view&id=20&Itemid=39) V0.40 + Postscript.dll V4.21 = Keine Fehlermeldung!
IrfanView (http://www.irfanview.com/) V4.22* + ImPDF (http://www.comsquare.ch/index.php?option=com_content&task=view&id=20&Itemid=39) V0.40 = Fehlermeldung!
IrfanView (http://www.irfanview.com/) V4.22* fix + ImPDF (http://www.comsquare.ch/index.php?option=com_content&task=view&id=20&Itemid=39) V0.41 = Fehlermeldung!

- mit installiertem GPL Ghostscript (http://sourceforge.net/project/showfiles.php?group_id=1897&package_id=108733) V8.63:

IrfanView (http://www.irfanview.com/) V4.20 + ImPDF (http://www.comsquare.ch/index.php?option=com_content&task=view&id=20&Itemid=39) V0.40 + Postscript.dll V4.20 = Keine Fehlermeldung!
IrfanView (http://www.irfanview.com/) V4.20 + ImPDF (http://www.comsquare.ch/index.php?option=com_content&task=view&id=20&Itemid=39) V0.40 + Postscript.dll V4.21 = Keine Fehlermeldung!
IrfanView (http://www.irfanview.com/) V4.22* + ImPDF (http://www.comsquare.ch/index.php?option=com_content&task=view&id=20&Itemid=39) V0.40 = Fehlermeldung!
IrfanView (http://www.irfanview.com/) V4.22* fix + ImPDF (http://www.comsquare.ch/index.php?option=com_content&task=view&id=20&Itemid=39) V0.41 = Fehlermeldung!

*) IrfanView (http://www.irfanview.com/) V4.22 beinhaltet stets 'Postscript.dll V4.22'


Mein Fazit:
Es scheint also bei der Version 4.22 von IrfanView (http://www.irfanview.com/) völlig egal zu sein, ob die ältere (bewährte)
AFPL (http://sourceforge.net/project/showfiles.php?group_id=1897&package_id=1845)- oder erstmalig die neueste GPL (http://sourceforge.net/project/showfiles.php?group_id=1897&package_id=108733)-Ghostscript (http://sourceforge.net/projects/ghostscript/)-Version verwendet wird!
Der Fehler muß in der Version 4.22 (und auch 4.22 fix) selbst zu finden sein!
Was mich anfangs wunderte, waren einige zufriedene Reaktionen (nach dem Hinweis auf das ImPDF (http://www.comsquare.ch/index.php?option=com_content&task=view&id=20&Itemid=39)-Plugin) in den älteren Fehlerberichten!
Aber mit Blick auf meine Testergebnisse ist dies ja nachvollziehbar, da bis Version 4.20 und korrekt installiertem ImPDF (http://www.comsquare.ch/index.php?option=com_content&task=view&id=20&Itemid=39)-Plugin das Speichern im PDF (http://de.wikipedia.org/wiki/Portable_Document_Format)-Format stets ohne Fehlermeldung verlief!

PS:
Ich möchte der Vollständigkeit halber anmerken, daß bei allen getesteten Varianten (ob nun mit oder ohne Fehlermeldung)
die erzeugte PDF (http://de.wikipedia.org/wiki/Portable_Document_Format)-Datei (an sich selbst) immer fehlerfrei war!

Frank
01.01.2009, 10:08 PM
Ich war in der letzten Zeit ein bißchen durcheinander gekommen wegen der vielen, möglich erscheinenden Variationen! Auf der einen Seite ist es jetzt prima, daß man (wenn man erweiterte Funktionen nutzen will) bei der zu installierenden Ghostscript (http://sourceforge.net/projects/ghostscript/)-Version frei wählen kann zwischen AFPL-Ghostscript (http://sourceforge.net/project/showfiles.php?group_id=1897&package_id=1845) und
GPL-Ghostscript (http://sourceforge.net/project/showfiles.php?group_id=1897&package_id=108733)! Auf der anderen Seite muß man (bei kurz aufeinander folgenden Versionswechsel aufgrund von nicht vermeidbaren, sich einschleichenden Fehlern) aufpassen, nicht den Überblick zu verlieren!
Hätte ich sorgfältiger gelesen, dann hätte ich gleich gemerkt, daß ich IrfanView (http://www.irfanview.com/) V4.23 mit dem
PlugIn-Paket "irfanview_plugins_422_setup.exe" hätte kombinieren müssen!
Da aber zuvor im Forum im Zusammenhang mit einer "V4.22fix"-Version von einem "ImPDF (http://www.comsquare.ch/index.php?option=com_content&task=view&id=20&Itemid=39) V.041"-PlugIn die Rede war, wollte ich natürlich auch IrfanView (http://www.irfanview.com/) V4.23 mit dem "ImPDF (http://www.comsquare.ch/index.php?option=com_content&task=view&id=20&Itemid=39) V.041"-PlugIn kombinieren!
(Man will halt immer von allem die aktuellste Version drauf haben!)

Das war aber ein Trugschluß!
Denn das "ImPDF (http://www.comsquare.ch/index.php?option=com_content&task=view&id=20&Itemid=39) V.041"-PlugIn war einzig für IrfanView (http://www.irfanview.com/) V4.22 gemacht!

siehe:
http://img387.imageshack.us/img387/9603/impdfkb4.jpg (http://www.comsquare.ch/index.php?option=com_content&task=view&id=20&Itemid=39)

So kam ich stets auf das folgende erste Ergebnis:

IrfanView (http://www.irfanview.com/) V4.23* + ImPDF (http://www.comsquare.ch/index.php?option=com_content&task=view&id=20&Itemid=39) V0.41 = Fehlermeldung!
Zum zweiten (und richtigem) Ergebnis kam ich leider reichlich spät, erst nach mehrfachem Durchlesen aller betreffenden Beiträge im deutschen sowie englischen Forum!

IrfanView (http://www.irfanview.com/) V4.23* + ImPDF (http://www.comsquare.ch/index.php?option=com_content&task=view&id=20&Itemid=39) V0.40 = Keine Fehlermeldung!


*) IrfanView (http://www.irfanview.com/) V4.23 beinhaltet 'Postscript.dll V4.22'

______________________________

Meine Erkenntnis:
Jetzt funktioniert's richtig!
Es ist besser, immer sorgfältig und wenn nötig mehrfach zu lesen!
Man kann sich nicht auf alles verlassen!
Auch eine aktuellere PlugIn-Version kann sonst "Ein Schuß in den Ofen" (http://www.redensarten-index.de/suche.php?suchbegriff=ein+Schuss+in+den+Ofen&bool=and&suchspalte%5B%5D=rart_ou) sein!