No announcement yet.

Windows 7 UAC pops up when I double-click a file of a type owned by irfanview (jpeg)

  • Filter
  • Time
  • Show
Clear All
new posts

    Reported Windows 7 UAC pops up when I double-click a file of a type owned by irfanview (jpeg)

    I've looked at lots of stuff around the web and tried many things. I'm running Irfanview 4.35, and I selected to put the .ini file in the recommended location for Windows 7 (which matches the recommendations in old reports of this). I have uninstalled IrfanView, cleaned all references out of the registry, and then reinstalled it (both manually and using REVO uninstaller).

    And I still get the UAC popup when I double-click a file of a type IrfanView owns.

    I can open IrfanView directly (from the program icon) without UAC intervention.

    I'm running Windows 7 Ultimate 64.

    Did you use the exe installer to install the program or some other method?
    If you used the installer and followed the recommendations you should have the program (i_view32.exe) in a folder called Irfanview in the Program files folder (or its 64bit equivalent) and the ini file (i_view32.ini) in that same folder should just contain the 2 lines


    Is that what you have?


      I used the .exe installer, and told it to put the .ini file in the recommended location for Windows 7 (as I said above).

      Double-checking now, C:\Program Files (x86)\IrfanView\i_view32.ini does indeed contain just the two lines you say it should.


        Not that then.
        I have UAC on its Default setting (see below). What setting do you have?
        Click image for larger version

Name:	UAC settings.jpg
Views:	1
Size:	42.9 KB
ID:	80890


          I would just like to say that I have this problem as well. I have been waiting for this issue to get resolved so I can start using Irfanview again but after uninstalling with Revo and reinstalling as recommended, UAC confirmation is still requested anytime the program is run. I keep my UAC on the level below Default (don't flash screen) but changing it to the default did not help. My OS is Windows 7 Home Premium 64-bit. I really would like to be able to use this program again if someone could figure out how to get around the UAC problem that, apparently, only some people are having. Thanks!


            Hey ... I resolved this problem. Since I don't know which action resolved it, I'll just list what I did. First, I tried changing i_view32.exe to 'Run as administrator' - didn't work, changed it back. I was reading up on all the things that can cause this situation and saw people talking about, in some cases, the program should only request UAC the first time a user ran it. I got to thinking about the fact that I had never directly run this program - I had only run it via an individual file's right click context menu 'Open with' and it always requested UAC. So, I created a desktop shortcut to the program and ran it from there. It did, indeed, still request UAC. But ... the next time I ran it from there, it didn't request UAC and it no longer requests UAC when run via the context menu. YAY!!! I imagine I could have done the same thing just running the program directly without creating the shortcut to run it. But, YAY!!! And thanks for this program!


              You will always get the "Open file - Security warning" dialog the first time you run a program after installation unless the program file uses a digital signature for validation. You need to uncheck the box that says "Always ask before opening this file" if you do not want it again. That is normal for Windows 7. I do not think that running it from a shortcut link makes any difference to that.


                Well, I'm sure it was a UAC warning and not "Open file - Security warning" because, believe me, had there been a box to uncheck to not keep getting the message I would have done that. I am aware of the difference between the two and what you are talking about - it was a UAC warning. I wish I had paid attention to which warning it was but I did not. I know what I'm saying happened doesn't make sense. If I weren't afraid of not being able to stop the UAC warnings again, I'd uninstall and re-install the program and pay more attention to exactly what happens. But, maybe I'll end up doing that anyway due to the next update I install. I was just trying to potentially help some of the few other people that have said here that they have the UAC issue. We'll see what happens on the next update. Thanks for your time.


                  Take a look in Irfanview at the Extensions tab in Properties/Settings. At the bottom of that dialog are various "Shell options: " that might be ticked. None of mine are. Are any of yours?


                    Hey, Mij! That's a good thought because, as you obviously know, a program wanting to modify the right click context menu will usually trigger UAC intervention. However, none of mine are checked and I would have never checked any as I keep my menu pared down as much as possible. Now, if any were already checked after installation, I would have unchecked them and that might have something to do with it but I don't recall having to ever uncheck any of those. Not that it probably matters, but I also do not have any file extensions associated and never did.
                    My case may be totally different than almost anyone else's with the problem anyway. I mean most people probably wouldn't have done what I do which is to not install the desktop shortcut (don't remember if that's an option) or, otherwise, delete the desktop shortcut right after installation. I had always accessed the program via "Open with". It wasn't until I created a desktop shortcut and ran the program from it that I stopped getting the UAC warning except for the first run from the shortcut. I mean, running from the shortcut would have been the first time the program was run on my system without an argument passed so, yeah, things would be being handled differently in the program due to that but I still don't get getting the UAC only the first time when run from the shortcut.
                    If I ever notice anything in the future that I think might shed some light, I'll let you know. Thanks so much for your time.
                    By the way, I handle any desktop shortcut accessed UAC issues by running the program through the Task Scheduler via the shortcut. UAC was a particular problem for me with your program only due to the fact that I was only accessing it via the "Open with" and I was having problems getting that to work when run through the the Task Scheduler. Though I may have been able to do it, I quit trying once I got the UAC turned off this other 'magical' way.
                    Last edited by Bobbob; 24.04.2013, 12:24 AM.