Announcement

Collapse
No announcement yet.

Flash4.dll is lacking from 4.57 plugin package and prevents the opening of swf files

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Flash4.dll is lacking from 4.57 plugin package and prevents the opening of swf files

    The set of plugins up to version 4.56 allowed to open swf files perfectly. However, the new set of plugins from version 4.57 does not have the Flash4.dll file. Without this library swf files cannot be opened. As a test, I transferred Flash4.dll to the current set of plugins and both version 4.56 and 4.57 of the IrfanView software opened the swf files without any problems. Therefore, if I am correct, it would be necessary to insert the Flash4.dll library in the latest plugin package.

    #2
    I verified that the file iv_formats.zip. contains de referred file (Flash4.dll) and its use resolve the problem on opening swf files. Nevertheless, I think that it will be important providing this dll within the complete plugins set.

    Comment


      #3
      Flash4 is a very old version standalone Flash decoder from 2000-2004. It cannot fully display most modern, interactive Flash programs. You'd need at least Flash 8 or 9. IrfanView normally uses the Internet Explorer component instead but it has recently stopped working because of a decision made by Adobe.

      Comment


        #4
        Flash Player plugin is not supported anymore. You can still use Flash Player Projector from Adobe.
        IrfanView 4.57 64bit, Windows 10 20H2

        Comment


          #5
          I would like to thank j7n and JendaLinda for their replies. (1) I navigated to the Adobe website at https://www.adobe.com/support/flashp...downloads.html and downloaded the 32-bit version for Windows (Download the Flash Player projector). The software opened the swf I need without problems, but outside of IrfanView. (2) It happens that on the IrfanView website the version available for download in its library package is precisely Flash4.dll (see https://www.irfanview.info/files/iv_formats.zip) and even the recent package 4.56 it was this plugin that was being distributed (If I'm not mistaken), it seems to me even in the portable version of the software at PortableApps.com. I think it is important that any functional library is already distributed when installing software version 4.57 and higher so that less experienced users do not have difficulties using IrfanView in its fullest. In addition, I thank you again for your help.

          Comment


            #6
            Flash playback in IrfanView was using the system Flash Player plugin (used in web browsers). This was recently deprecated by Adobe. Flash was completely disabled in web browser. Applications depending on the web browser Flash plugin also stopped working.

            The Flash Player projector is a workaround, if you really need to use a Flash application. The idea was the Flash Player should be replaced with a different technology. Adobe has no intention to develop Flash anymore, or fix bugs and vulnerabilities.
            IrfanView 4.57 64bit, Windows 10 20H2

            Comment

            Working...
            X