Page 3 of 4 FirstFirst 1 2 3 4 LastLast
Results 21 to 30 of 40

Thread: Patchday Thread Archive

  1. #21
    Professional User Mij's Avatar
    Join Date
    Mar 2007
    Location
    Camberley, Surrey, UK
    Posts
    2,764
    Version
    IrfanView 4.51
    OS
    32-bit Win 10
    CPU Cores
    3

    Default

    Stefan. It is a real nightmare.
    I am afraid that none of that works with Firefox. You cannot accept the certificate because it will not let you. I have deleted cookies, cache, Active logins, offline Website data, any Bookmarks relating to Irfanview forum. I also opened About:config, searched for and deleted the reference to Irfanview that I found there. After deleting all history I now can see none at all when I ask to view all history, but it is still somewhere because as soon as I enter the new forum URL a drop down list appears of just about every place on the old forum I have ever visited.

    Fortunately Chrome does allow me to come here but I fear we may be about to lose a lot of members unless we can sort this out.

  2. #22
    Administrator
    Join Date
    May 2007
    Location
    Near Munich, Germany
    Posts
    894
    Version
    IrfanView 4.33
    OS
    64-bit Linux Distribution
    CPU Cores
    8

    Default

    Hi,

    do you get the same problems, when you try to access our status site via a ssl proxy -> https://ssl-account.com/irfanview-fo...atus/index.cgi

    Stefan

  3. #23
    Professional User Mij's Avatar
    Join Date
    Mar 2007
    Location
    Camberley, Surrey, UK
    Posts
    2,764
    Version
    IrfanView 4.51
    OS
    32-bit Win 10
    CPU Cores
    3

    Default

    No just the same result. As soon as it is redirected to anywhere on http://irfanview-forum.de it is changed to a https prefix and the security message appears. The Technical detail given is that the certificate is only valid for the following names
    *.kasserver.com, kasserver.com

    I had already tried creating a tinyurl for the new site name to see if that worked but as soon as it was redirected that same message appeared.

  4. #24
    Multiple User Jacal's Avatar
    Join Date
    Jun 2013
    Location
    Europe
    Posts
    332
    OS
    64-bit Win 10
    CPU Cores
    4

    Default

    I had the same problem Mij described, cleaning cookies, bookmarks, permissions, history etc. didn't help. Then I've tried some firefox add-ons.

    Remember Certificate Exception 4.0 did not help, but Skip Cert Error 0.4.0 did.

    https://addons.mozilla.org/fr/firefo...ip-cert-error/

    I suppose not many users would want to use this add-on though. For some reason now I can enter the forum even after I have disabled and later uninstalled it.

    This is certainly not a solution, only a clumsy workaround, but perhaps it can be of some help.

    Tested on cyberfox 24 and firefox 25, using the same profile.

  5. #25
    Administrator
    Join Date
    May 2007
    Location
    Near Munich, Germany
    Posts
    894
    Version
    IrfanView 4.33
    OS
    64-bit Linux Distribution
    CPU Cores
    8

    Default

    Quote Originally Posted by Mij View Post
    As soon as it is redirected to anywhere on http://irfanview-forum.de it is changed to a https prefix and the security message appears.
    That's not good. I am trying to reproduce the error on a windows machine with Firefox locally and will write again here.

  6. #26
    Administrator
    Join Date
    May 2007
    Location
    Near Munich, Germany
    Posts
    894
    Version
    IrfanView 4.33
    OS
    64-bit Linux Distribution
    CPU Cores
    8

    Default

    Could you please upload a screenshot with the Firefox error message (when accessing https://irfanview-forum.de). Thanks!

  7. #27
    Professional User Mij's Avatar
    Join Date
    Mar 2007
    Location
    Camberley, Surrey, UK
    Posts
    2,764
    Version
    IrfanView 4.51
    OS
    32-bit Win 10
    CPU Cores
    3

    Default

    OK Stefan. The attachments show as follows:
    01 The http URL is set. About to press Enter.
    02 Enter pressed. The URL has changed to https and the Untrusted site dialog box displayed.
    03 Technical details has been clicked and these details are added. There is no way out of this dialog other than to press Get me out of here
    04 Now the Skip-Cert-Error add-on has been installed as suggested by Jacal. The dialog box now includes an Add exception button
    05 Add exception has been pressed and another dialog box appears.
    06 Clicking the Get certificate button displays this certificate

    The first time I clicked Confirm Security Exception a message appeared that read "SkipCertError could not add an exception for irfanview-forum.de, because the following options are not set : domain mismatch"
    Since then nothing happens when I click that button. I have tried leaving location set to the https URL and manually editing it to the http version but it makes no difference.
    So still no progress for me even using the add-on.

    Click image for larger version. 

Name:	01 Http URL set.png 
Views:	289 
Size:	93.2 KB 
ID:	3711 Click image for larger version. 

Name:	02 Untrusted site dialog.png 
Views:	261 
Size:	98.1 KB 
ID:	3712 Click image for larger version. 

Name:	03 With Technical details.png 
Views:	277 
Size:	22.5 KB 
ID:	3713 Click image for larger version. 

Name:	04 With Skip-Cert_Error  add-on.png 
Views:	286 
Size:	111.1 KB 
ID:	3714 Click image for larger version. 

Name:	05 Add exception.png 
Views:	268 
Size:	59.1 KB 
ID:	3715 Click image for larger version. 

Name:	06 Get certificate.png 
Views:	280 
Size:	34.1 KB 
ID:	3716

  8. #28
    Administrator
    Join Date
    May 2007
    Location
    Near Munich, Germany
    Posts
    894
    Version
    IrfanView 4.33
    OS
    64-bit Linux Distribution
    CPU Cores
    8

    Default

    Hi,

    a solution for this is coming in the next hours!

    Stefan

  9. #29
    Administrator
    Join Date
    May 2007
    Location
    Near Munich, Germany
    Posts
    894
    Version
    IrfanView 4.33
    OS
    64-bit Linux Distribution
    CPU Cores
    8

    Default

    Hi,

    please try to visit https://irfanview-forum.de now - it should redirect to http://irfanview-forum.de, without an invalid certificate notification.

    If that's working, I can redirect from the http://irfanview-forum to the secure https connection - as we got a valid certificate now!

    Stefan

  10. #30
    Professional User Mij's Avatar
    Join Date
    Mar 2007
    Location
    Camberley, Surrey, UK
    Posts
    2,764
    Version
    IrfanView 4.51
    OS
    32-bit Win 10
    CPU Cores
    3

    Default

    Hi Stefan
    In Firefox I am now automatically redirected to the https site shown in the attachment, which just displays a text version of the forum. Is that what you expect?
    In Firefox I still cannot log in to this http site that I use Chrome to reach and which shows the normal graphical version of the forum.

    Click image for larger version. 

Name:	IV forum display.png 
Views:	269 
Size:	85.9 KB 
ID:	3719

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •