Results 1 to 10 of 10

Thread: Problem with non-english characters in folder's names

  1. #1
    IV Amateur
    Join Date
    Oct 2014
    Posts
    15
    Version
    IrfanView 4.51
    OS
    32-bit Win XP Pro SP3
    CPU Cores
    2

    Unhappy Problem with non-english characters in folder's names

    I had this problem before when I use F7, F8 (copy, move files) and create new folder with name that contain special characters - in my case - polish letters like: ą, ę, ź, ó, ż, etc.

    Now I was very happy about DRAG and DROP function in IrfanView. I've really missed that one.
    But because of problem with non-english charaters — I can't fully use Drag'n'Drop function

    Here is situation.
    - In outlook express I create new message (new message window appears).
    - In IrfanView I've open some picture.
    - I drag'n'drop this picture from IrfanView to New Message Window.
    - If this picture is in folder which name contain polish letters, then when I try to send e-mail I've got a message like: "Can't send the file attached to message. The file can't be found" or something like that.
    - If the picture is in folder which name contain only english letters — everything is fine.

    Look at the screenshot (attached to the post). This is OutlookExpress new message window with files attached. On left you see the file drag'n'droped (from irfanView) from folder that contain polish letters and on the right you have the same file drag'n'droped from folder that doesn't contain polish letters. As you can see the 'bad' file doesn't show the filesize.

    Another thing
    If the structure is like...c:\folder 1\folder 2\folder 3\folder with polish letters\PICTURE.jpg.....then it's not properly drag'n'droped.
    But also if structure is like...c:\folder 1\folder with polish letters\folder 3\PICTURE.jpg ... then it's also not properly drag'n'droped.

    Also when name of the FILE itself contain polish letters it's also drag'n'droped not properly (in outlookexpress new message window it shows some strange file name and don't show file size).

    Problem with non-english charaters in folder's name or file's name.

    Windows XP
    IrfanView version 4.38
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	irfanview-drag'n'drop.jpg 
Views:	273 
Size:	5.1 KB 
ID:	3989  
    Last edited by Rhotax; 18.12.2014 at 09:41 PM.

  2. #2
    IV Newbie
    Join Date
    Mar 2013
    Location
    D/FW area, Texas -- U.S.A.
    Posts
    2
    Version
    IrfanView 4.38
    OS
    64-bit Win Vista Ultimate SP2
    CPU Cores
    8

    Default

    Will there a be a fix concerning the problem with "special characters" used in folder names ?? IrfanView will not SAVE or OPEN valid graphic files if they are in a folder (or some sub-folder) where "special characters" are used anywhere within the Path Name. All one gets is the typical message saying:

    "Unknown file format, empty/damaged file or file not found!"

    But there is nothing wrong with the graphic file... it is a valid file and works quite well when not under the path which has a folder with "special characters". BTW, this is on a Win-7 64-bit machine.

  3. #3
    Moderator
    Join Date
    Aug 2007
    Location
    Germany
    Posts
    855
    Version
    IrfanView 4.51
    OS
    64-bit Win 10
    CPU Cores
    8

    Default

    Hi,

    is the Unicode plugin loaded (Properties -> Language -> Load Unicode Plugin at program start)?

    Regards
    Nils

  4. #4
    IV Amateur
    Join Date
    Oct 2014
    Posts
    15
    Version
    IrfanView 4.51
    OS
    32-bit Win XP Pro SP3
    CPU Cores
    2

    Default

    In my case - it is.

  5. #5
    Moderator
    Join Date
    Aug 2007
    Location
    Germany
    Posts
    855
    Version
    IrfanView 4.51
    OS
    64-bit Win 10
    CPU Cores
    8

    Default

    @Rhotax: does it work if you drag'n'drop the image from the Windows Explorer directly?

  6. #6
    IV Amateur
    Join Date
    Oct 2014
    Posts
    15
    Version
    IrfanView 4.51
    OS
    32-bit Win XP Pro SP3
    CPU Cores
    2

    Default

    Yes, it does.

  7. #7
    IV Amateur
    Join Date
    Oct 2014
    Posts
    15
    Version
    IrfanView 4.51
    OS
    32-bit Win XP Pro SP3
    CPU Cores
    2

    Default

    New observation.
    When I use F7/F8 (move/copy file) and create new folder wich name consist polish characters...it's creates two folders. One with proper name (with polish characters) and other with some "strange" characters. What's more, the files are copied/moved correclty (to the folder with polish characters).

  8. #8
    IV Amateur
    Join Date
    Oct 2014
    Posts
    15
    Version
    IrfanView 4.51
    OS
    32-bit Win XP Pro SP3
    CPU Cores
    2

    Default

    Is there a some new version of Irfan View where this issue with non-english characters (mentioned in this topic) is fixed?

  9. #9
    Moderator Enterprise User Bhikkhu Pesala's Avatar
    Join Date
    May 2007
    Location
    East London
    Posts
    6,332
    OS
    64-bit Win 10
    CPU Cores
    1

    Default

    IrfanView 4.51 is the latest version. Please install it and update your forum profile.

    Let us know if the latest version solves your issue.

  10. #10
    IV Amateur
    Join Date
    Oct 2014
    Posts
    15
    Version
    IrfanView 4.51
    OS
    32-bit Win XP Pro SP3
    CPU Cores
    2

    Default

    YES! It works! Finally After sooo many years

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •