Results 1 to 8 of 8

Thread: Windows 10 UWA Apps icons all change to Irfanview icons

  1. #1

    Question Windows 10 UWA Apps icons all change to Irfanview icons

    Hi everyone, this is my first post.

    I did some searching earlier and I saw posts relating to Windows Explorer icons

    However this relates to Universal Windows App icons, I have attached some images to show.

    In this image, Alarms & Clock appears fine
    Click image for larger version. 

Name:	alarm-clock-normal.jpg 
Views:	482 
Size:	118.9 KB 
ID:	5388

    However in this image, it's icon is replaced by Irfanview
    Click image for larger version. 

Name:	alarm-clock-ouch.jpg 
Views:	483 
Size:	109.3 KB 
ID:	5389

    And the same happens to Mail and Settings
    Click image for larger version. 

Name:	mail+settings-ouch.jpg 
Views:	354 
Size:	116.4 KB 
ID:	5390

    I have no idea how to fix it. I removed all irfanview file associations and then custom set them myself, and I cleared the Windows icon cache. Please help because this is really annoying.

  2. #2
    IV Newbie
    Join Date
    Mar 2019


    I'm having the same issue. Have you found a solution?

  3. #3


    Same here on Windows 10 1809, IrfanView 4.53 64-bit.. I notice that specifically it is using the PCX icon.
    Click image for larger version. 

Name:	2019-06-06 10_15_57-Download IrfanView latest release.png 
Views:	119 
Size:	14.9 KB 
ID:	5595

  4. #4


    Oh my god someone else with this issue. Have you managed to find a solution? I cleared the icon cache and stuff, but nothing's worked so far.

    It drives me insane.

  5. #5


    Same problem, ugly red icon remains for all programs in Start Menu even after complete uninstall with registry cleanup. How do I get rid of this nasty trash?


  6. #6


    I'm having the same issue - on all our family laptops running different types of Windows 10 (1806, 1903, 1909) and display languages.

    Uninstalling IrfanView did not change anything! This is so bad!


  7. #7


    Dear Sufferes

    I've found a solution to fix the icon of my "Calculator"-App:
    1. hit Windows-Key
    2. start typing the name of your troublesome "App", e.g. "Calc..."
    3. in the context menue of the App choose "App Settings"
    4. in the app Settings, scroll down, and hit "reset"
    5. wait until app is reset

    my Calculator App does now show the original Calculator-Icon.


  8. #8
    IV Newbie
    Join Date
    Mar 2020


    Nothing seems to be helping here. Not even the last solution(tried rebooting after it too).

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts