Results 1 to 3 of 3

Thread: Background Colour Change Problem

  1. #1

    Default Background Colour Change Problem

    I've not noticed this before because I have not wanted to change the IrfanView default background colour recently but it appears that option is now no longer working.

    This is for IrfanView v4.51 64bit: my background colour is set to white by default and I wanted to change it to black as I was dealing with a number of images with white and transparent backgrounds. I needed to differentiate the two so changing the backcolour to black was the best solution.

    It just will not change: I select black it shows that as the colour selected but when you click OK to apply nothing happens. I've tried closing and restarting IrfanView, rebooting the PC, opening as admin ie. all the usual stuff and nothing changes. An earlier 32bit version I have swaps to any colour I choose immediately.

    I checked the AppData > Roaming > Irfanview > 64bit configuration file and oddly the back colour is shown as "16777215" despite being white which I would expect to be either set as value "1" or a hexadecimal "FFFFFFFF". I checked the 32bit file and the black back colour value I had set that to use was shown as "0" so I used that with the 64bit version and voila: black background.

    My assumption was the 64bit configuration file was corrupted so I backed it up and deleted the original, restarted the PC then IrfanView and..........the problem returned. The newly written configuration file in AppData was showing the same "16777215" back colour (white) and that could not be changed.

    Something is definitely wrong with v4.51 because the rest of those settings must have been default and so none of my previous users preferences could have caused this and how could they anyway?

    Can someone else here using v4.51 test this on their system and report the result here? Thanks.
    Last edited by BadRobot2018; 31.12.2018 at 02:21 PM.

  2. #2
    Moderator Enterprise User Bhikkhu Pesala's Avatar
    Join Date
    May 2007
    Location
    East London
    Posts
    5,964
    OS
    64-bit Win 10
    CPU Cores
    1

    Default

    Update to 4.52 and test it again. If it is not broken in 4.52, then a bug in earlier versions won't be fixed.

    Here, the window background colour changes at once (from black to white) in the screenshot, but the transparent background of the loaded image does not change until the image if reopened.

    It was always thus as far as I can recall.

    Click image for larger version. 

Name:	Background Colour.png 
Views:	30 
Size:	84.1 KB 
ID:	5465
    Last edited by Bhikkhu Pesala; 31.12.2018 at 03:11 PM.

  3. #3

    Default

    Sorted the problem: my bad. For some reason the main 64bit version option menu was actually highlighting the Full Screen/Slideshow. I do not use that and never have so why I was there or did not notice I can not say.

    It should have been on the Viewing menu option and I can confirm that is working as it is supposed too.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •