Results 1 to 3 of 3

Thread: Updates

  1. #1
    IV Newbie
    Join Date
    Feb 2019
    Posts
    1
    OS
    64-bit Win 10
    CPU Cores
    6

    Smile Updates

    Hello Irfanviewers. Quick question or two. Is the RIOT plugin not updated with the main RIOT version? IFV is back at 042 and 060 was released a month or two prior to IFV 452.

    Second, the forum's profile page asks which version of IFV is used and offers up to 451. It needs an update. I might request whichever todo list it falls on receive a note to "add the date to the download page" allowing people to know the date of the last update. That one might be author purview. If so please disregard.

    Your project is greatly appreciated. I sent you a donation. Keep up the good work.

  2. #2
    Hobby User Kuki Dent's Avatar
    Join Date
    Jun 2010
    Location
    Germany, Lower Saxony
    Posts
    182
    Version
    IrfanView 4.51
    OS
    64-bit Win 10
    CPU Cores
    4

    Default

    Hi,

    from https://www.irfanview.com/plugins.htm:
    RIOT - (version 0.3.3.0): allows IrfanView to save optimized JPG/GIF/PNG files (RIOT - Radical Image Optimization Tool)
    The basic PlugIn version will be installed with IrfanView PlugIns. An advanced (or newer) version can be downloaded here: http://luci.criosweb.ro/riot/download/

    The owner of the forum (see https://irfanview-forum.de/intro/imprint.htm) obviously is not interested in an update to the profile-page.
    When the power of love overcomes the love of power, the world will know peace - Jimi Hendrix

  3. #3

    Default

    I'm was interested in this and looked to see what RIOT version I had. The Riot.dll installed from the latest plugins pack (v4.52), installed in Plugins > Plugins32 even if you're using a 64bit system, is v0.4.6.0.

    I followed that link above and downloaded the latest RIOT for plugins, apparently, v0.6.1. That is an EXE which installs RIOT or more precisely the RIOT documentation as a program complete with an uninstaller. During the install you have the choice of which graphics program(s) you want to use with the RIOT plugin. That includes IrfanView of course.

    I'd moved the existing Riot.dll v0.4.6.0 plugin as backup before doing this expecting it to be replaced by a new one. But no, on launching IrfanView and then rechecking the plugins there was nothing. I thought I may have misunderstood and it had been added to the RIOT Program Files (x86) or a Program Files folder.....no. Next I checked Windows, both System32 ans SysWOW64 folders, nothing there that I could see either.

    In the end I did a thorough Revo uninstall of RIOT and reinstated the v0.4.6.0 Riot.dll plugin backup.

    So did I misunderstand how the 'advanced' or newer version is meant to work or be installed by the RIOT.exe for the plugin to be used by IrfanView.
    Last edited by BadRobot2018; 06.02.2019 at 11:18 PM.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •