Results 1 to 4 of 4

Thread: UAC prompt after IrfanView32 update

  1. #1
    IV Newbie
    Join Date
    Jun 2017
    Posts
    5
    Version
    IrfanView 4.51
    OS
    64-bit Win 8.1 Pro
    CPU Cores
    2

    Default UAC prompt after IrfanView32 update

    I attempted to update IrfanView 32 (IV32) from 4.5.3 to 4.5.4 by simply overwriting the existing directory under Program Files (x86) with those from the ZIP file.
    However, IV 32 now shows a UAC prompt every time I start it. If I respond "No" to the prompt, IV32 still works.
    I have my INI files in %APPDATA%\IrfanView and have tried changing the value of "INI_Folder=" in c:\Program Files (x86)\IrfanView\i_view32.in as recommended in the FAQ and I have also tried deleting c:\Program Files (x86)\IrfanView\i_view32 completely, but the problem persists.
    I can only assume that the UAC prompt has something to do with IrfanView trying to access the file associations, as mentioned in this FAQ article:
    How to Upgrade IrfanView: Is it necessary to uninstall the older version before installing the newer version?
    Why should anything in the file associations change or need changing?

  2. #2

    Default

    The UAC prompt is usually only seen if the program executable (.exe) is set to run as administrator.

    I've downloaded both 64bit and 32bit ZIP version from the approved source and neither is set to run as administrator by default.

    Why were you using the ZIP version for overwriting the installed version? The ZIP one is effectively a portable app although it does write stuff to the HDD I believe.

    What you should be using for an installed version update is the .exe installer. TBH it is so long since I used it (I use 'portable' versions of both flavours) I can not remember whether it automatically deletes the existing installation or requires you to do it first. But it should tell you one way or another.

    I'm guessing the UAC prompt IS caused by using the ZIP version to update your installation. Its executable won't have the same permission to access the installed versions files. In fact I've just checked on another PC with an installed 64bit version and that .exe has very specific permissions whilst the ZIP version does not have any Security options at all.

    So if you substituted an installed .exe with the zip .exe without those permissions it is not surprising the UAC prompt kicks in on launch but also not surprising it still launches even if you click on the No. The ZIP .exe should launch from anywhere (it is portable) so, I'm guessing again, it does that but will not be allowed to access certain files used by the installed version. However they may not be essential to it actually working.

    Up to you but my thoughts are: you've messed up your existing installation big time and it is impossible to say for sure how to fix it. Why bother to try anyway? It will be quicker and safer to blitz everything and start afresh IMHO. If you have any custom settings or use plugins they will be lost but it'll still be quicker to redo/reinstall those than anything else.

    Download and install Revo Uninstaller tool or preferred alternative. Use it to uninstall IRFV and the Advanced settings to get rid of leftovers. It will put in a Restore Point so if you have any problems you can roll the changes back.

    As you have mixed up portable and installed files it may leave some of the portable files behind so you should delete those manually.

    Now either:-

    Download the ZIP version you want and treat it like it is portable. You can put it wherever you want - I have a folder on C:\ for such portable programs but it could just as well be in Documents or on another drive. Create a shortcut to the .exe for your Desktop or wherever you prefer that to be.

    or:-

    Download the .EXE version and fresh install that.

    Either should launch without the UAC prompt. If it does not I'd guess there must have been leftovers you missed. Most likely User Account name > AppData > Roaming > Irfanview.
    Last edited by BadRobot2018; 03.02.2020 at 12:58 AM.

  3. #3
    Multiple User Kuki Dent's Avatar
    Join Date
    Jun 2010
    Location
    Germany, Lower Saxony
    Posts
    249
    Version
    IrfanView 4.51
    OS
    64-bit Win 10
    CPU Cores
    4

    Default

    Hi rsbrux,
    still using 64-bit Win 8.1 Pro?
    I don't remember how it was with Win 8.1, since I changed to Win10 as soon as possible. With Win10 it is better to install IrfanView and the Plugins via
    the .EXE installation routine. Start the Installation with admin rights.
    You also should start IrfanView with admin rights. To do so, right click on the link to IrfanView > Properties > Compatibility > Start program as
    administrator > OK (the way with Win10).
    This should prevent the UAC to ask you every time you start IrfanView.
    Win 10/64 Home v1909 IrfanView 4.54/32
    Hate has caused a lot of problems in this world, but it has not solved one yet. (Maya Angelou)

  4. #4

    Default

    So Win10 has reversed that from the default for earlier Windows versions. Why am I not surprised?

    With Win7 and likely Win8/8.1 running something as administrator either from the right-mouse click context menu or via Properties > Compatibility is the very thing that provokes the UAC prompt when launching a program.

    Some programs are set up by default to provoke UAC on launch (not IRFV) and there are ways of disabling that using either a third party program designed for the purpose or via Task Scheduler and a shortcut with elevated privileges. Information on doing this is easily found.

    In this case the installed version has obviously been messed up so cleaning out the problem and doing a fresh install seems to me the most sensible solution to suggest. Up to rsbrux but I thought the whole point of his post was to get rid of the UAC prompt.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •