Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12

Thread: New errors after installing 4.56. WEBP files

  1. #1
    IV Beginner
    Join Date
    Oct 2014
    Posts
    25
    Version
    IrfanView 4.51
    OS
    32-bit Win XP Pro SP3
    CPU Cores
    2

    Question New errors after installing 4.56. WEBP files

    In some older version, when IrfanView meet .webp files, I get info that "the file has incorrect extension, change it to .jpg?" I was happy to answer YES.
    Now, first I get error: InitializeCriticalSectionEx in KERNEL32.dll and then another window
    "Can't load PlugIn: "WEBP.DLL!
    Please install or update PlugIns from IrfanView homepage and/or enable the PlugIn in 'Help->PlugIns' menu.
    (32 bit)."

    I've checked help->PlugIns and there is WEBP.DLL but Version: Unknown, Info/Formats: Unknown (maybe 64 bit?)

    I've download WEBP plugin from here https://www.irfanview.com/plugins.htm and... nothing changed.

  2. #2
    Moderator Enterprise User Bhikkhu Pesala's Avatar
    Join Date
    May 2007
    Location
    East London
    Posts
    6,639
    OS
    64-bit Win 10
    CPU Cores
    1

    Default

    The latest plugins were released after 4.56 and are version 4.57. They show up correctly in the Installed Plugins list for both 32-bit and 64-bit.

    All of my WebP images open just fine.

  3. #3
    IV Beginner
    Join Date
    Oct 2014
    Posts
    25
    Version
    IrfanView 4.51
    OS
    32-bit Win XP Pro SP3
    CPU Cores
    2

    Default

    Quote Originally Posted by Bhikkhu Pesala View Post
    The latest plugins were released after 4.56 and are version 4.57.
    I've checked and I have version 4.57.

    So I guess I need to go back to older, working version.

    PS
    Oh no! Where to find older versions of plugins?
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	webp.jpg 
Views:	34 
Size:	9.6 KB 
ID:	6020  
    Last edited by Rhotax; 07.11.2020 at 12:46 PM.

  4. #4
    Moderator Enterprise User Bhikkhu Pesala's Avatar
    Join Date
    May 2007
    Location
    East London
    Posts
    6,639
    OS
    64-bit Win 10
    CPU Cores
    1

    Default

    The 4.56 versions are in the plugin installers.

    Attach a WebP file (Zipped) to see if anyone else can reproduce the issue.

    Please update your profile signature. Are you still using Win XP Pro SP3? That might be the issue.

  5. #5
    IV Beginner
    Join Date
    Oct 2014
    Posts
    25
    Version
    IrfanView 4.51
    OS
    32-bit Win XP Pro SP3
    CPU Cores
    2

    Default

    Quote Originally Posted by Bhikkhu Pesala View Post
    The 4.56 versions are in the plugin installers.

    Attach a WebP file (Zipped) to see if anyone else can reproduce the issue.

    Please update your profile signature. Are you still using Win XP Pro SP3? That might be the issue.
    I need last properly working version - 4.51.

    If everything worked fine, and I didn't change anything (like Win XP..) then the NEW occuring issue is not on my side.

    If in the "history of changes" there will be something like: "No longer support for windows XP" then...I will understand and I stay with last working version. And I will never say something bad about new versions

    PS
    haha I can upload the .webp file.
    It says "Upload errors [name of file] - Invalid file"

  6. #6
    Moderator Enterprise User Bhikkhu Pesala's Avatar
    Join Date
    May 2007
    Location
    East London
    Posts
    6,639
    OS
    64-bit Win 10
    CPU Cores
    1

    Default

    The forum does not support WebP. That is why I said:
    Quote Originally Posted by Bhikkhu Pesala View Post
    Attach a WebP file (Zipped) to see if anyone else can reproduce the issue.

  7. #7
    IV Beginner
    Join Date
    Sep 2020
    Location
    Czech Republic
    Posts
    69
    OS
    64-bit Win 10
    CPU Cores
    4

    Default

    I can confirm that webp does not work in IV 4.56 in Windows XP. Tested in the Virtual machine.

    Anyway, this is not a bug IMO. The core program is compatible with WinXP, but the plugins may not be compatible.
    Last edited by JendaLinda; 07.11.2020 at 06:53 PM.
    IrfanView 4.57 64bit, Windows 10 20H2

  8. #8
    IV Beginner
    Join Date
    Oct 2014
    Posts
    25
    Version
    IrfanView 4.51
    OS
    32-bit Win XP Pro SP3
    CPU Cores
    2

    Default

    Ok, so just for the record...the .zip file of some my .webp

  9. #9
    Moderator Enterprise User Bhikkhu Pesala's Avatar
    Join Date
    May 2007
    Location
    East London
    Posts
    6,639
    OS
    64-bit Win 10
    CPU Cores
    1

    Default

    For the record, the image opens fine in IrfanView 4.56 32-bit and 64-bit with the 4.57 WebP plugin.

  10. #10
    IV Beginner
    Join Date
    Oct 2014
    Posts
    25
    Version
    IrfanView 4.51
    OS
    32-bit Win XP Pro SP3
    CPU Cores
    2

    Default

    Quote Originally Posted by Bhikkhu Pesala View Post
    For the record, the image opens fine in IrfanView 4.56 32-bit and 64-bit with the 4.57 WebP plugin.
    In what windows (for the record)?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •