Results 1 to 3 of 3

Thread: MCI device error

  1. #1

    Default MCI device error

    (Don't ask me why, but I can't go to http://irfanview-online.com/vb/profi...do=editprofile)

    I am on XP pro. I just upgraded irfanview from 3.85 to 4.20 and now I get this message:

    Error: Windows can't play this file!

    Windows error text: The specified file cannot be played on the specified MCI device. The file may be corrupt, not in the correct format, or no file handler available in this format...

    Now it doesn't matter what version I use, going back to 3.85 doesn't work anymore, I get the same error.

    I have read many times to "go to directshow option in properties> video."

    I can't find this. Under options > properties there is only video/sound and there is no "direct show" there. Where is it?

    I have downloaded klmcodec434.exe and still same error. I think that iview is not finding the codecs, but I have no idea how to fix this.

    Any help is appreciated.

  2. #2
    Professional User Mij's Avatar
    Join Date
    Mar 2007
    Location
    Camberley, Surrey, UK
    Posts
    2,764
    Version
    IrfanView 4.51
    OS
    32-bit Win 10
    CPU Cores
    3

    Default

    The same question was previously posted here and did not get a solution.

    As for the Options you asked about, I assume that these are the ones in the IV player. To get to them you need to open IV_Player.exe which you will find in your plugins folder (probably at C:\Program files\Irfanview\Plugins). Click on IV_Player.exe to open it and you will find options as one of the icons on the left.
    Sorry, I cannot advise on best settings. This is not really my province.

  3. #3
    Professional User Skippybox's Avatar
    Join Date
    Jul 2008
    Location
    Detroit, MI USA
    Posts
    2,018
    Version
    IrfanView 4.25
    OS
    32-bit Win XP Home SP2
    CPU Cores
    1

    Default

    What file type are you trying to open? When you upgraded to 4.2, did you upgrade all your plugins as well?

    The DirectShow option is available in Options>Properties/Settings>Video/Sound tab. Choose Use internal video/sound player and check below it Use DirectShow for playing. If no luck playing, try Use external player. Go to Options>Start Multimedia Player and select the fourth icon, Options (key P). Change Play videos/sounds through to Microsoft Media Player interface (recommended if you have MS Media Player installed!). If still no luck, you'll have to dig deeper to determine what's the matter. Of course, you may be trying to play something unsupported.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •