Results 1 to 8 of 8

Thread: Windows 7 command line for slideshow not working

  1. #1

    Smile Windows 7 command line for slideshow not working

    Hi, Using Irfanview 4.25 on Windows 7 op sys with Dual Processors at 64bit. Last op sys was Vista Ultimate and no problem with command line option using Microsoft Digital Keyboard with Intellitype (using one of the customisable keys) - all software has been updated to current drivers.

    With Windows 7 and making sure that I have the correct command line characters and path etc I get an error msg that says can't find the file. Without the switch Irfanview opens ok with the command line option in the keyboard custom key.

    I am running Irfanview as Admin' and have checked to make sure the permissions on the folders are open to everyone. The txt file is there and appears ok. Is there something I'm missing?

    Many thanks for your anticipated held. Barbershopjohn.

  2. #2
    Professional User Mij's Avatar
    Join Date
    Mar 2007
    Location
    Camberley, Surrey, UK
    Posts
    2,763
    Version
    IrfanView 4.51
    OS
    32-bit Win 10
    CPU Cores
    3

    Default

    Where have you put your text file? An application running in Windows 7,as in Vista, does not automatically inherit User permissions, not even those of the Everyone user group.
    First step I would take is to put the file somewhere where I was sure the application would have access, such as the current Desktop. If it is found there then you know that you have a "permissions" problem. If not, you can probably eliminate that possibility.

  3. #3
    Advanced User matera's Avatar
    Join Date
    May 2006
    Location
    3 miles below poverty level
    Posts
    1,383
    Version
    IrfanView 4.44
    OS
    64-bit Linux Distribution
    CPU Cores
    4

    Default

    And AFAIK Win7 has its own set of UAC bugs.

    I'm waiting for 8 *snicker*
    Its: Belongs to "It"
    It's: Shortened form of "It is"
    ---------------------
    Lose: Fail to keep
    Loose: Not tight

    ---------------------
    Plurals do not require apostrophes

  4. #4

    Default

    Hi Mij, thanks for your suggestion. I had put it in the Irfanview folder and changed the permissions to everyone. I had also put it into C:\ and have now followed your suggestion and put it on my Desktop but with no success. These are the words from the error pop up. "Windows cannot find 'C:\Program files (x86)\IrfanView\i_view32.exe /slideshow=C:\Users\John\Desktop\Myslideshow.txt'. Make sure you typed the name correctly and then try again.
    regards Barbershopjohn

  5. #5

    Default

    Hi Matera, thanks for your thoughts. I disabled the UAC (not sure about the bugs) then rebooted to make sure but that did not have any effect...still got same error msg,
    thanks John

  6. #6
    Professional User Mij's Avatar
    Join Date
    Mar 2007
    Location
    Camberley, Surrey, UK
    Posts
    2,763
    Version
    IrfanView 4.51
    OS
    32-bit Win 10
    CPU Cores
    3

    Default

    Quote Originally Posted by Barbershopjohn View Post
    Hi Mij, thanks for your suggestion. I had put it in the Irfanview folder and changed the permissions to everyone. I had also put it into C:\ and have now followed your suggestion and put it on my Desktop but with no success. These are the words from the error pop up. "Windows cannot find 'C:\Program files (x86)\IrfanView\i_view32.exe /slideshow=C:\Users\John\Desktop\Myslideshow.txt'. Make sure you typed the name correctly and then try again.
    regards Barbershopjohn
    Right. I suspect from that error message that Windows misunderstands your command line. Is the folder really called Program files (x86)? If there are spaces in a folder or file name then you will usually need to put the path between inverted commas i.e "C:\Program files (x86)\Irfanview\i_view32.exe" /slideshow=C:\Users\John\Desktop\Myslideshow.txt. That will ensure that Windows treats the space before /slideshow... as the path terminator and not one in the middle of the folder name.

  7. #7

    Thumbs up problem resolved

    Hi Mij
    many thanks for your observations which have proved to be correct. I did as you said and put the first path into quotes and it worked plus I then enabled UAC and it still works fine. Again many thanks. regards John

  8. #8
    Advanced User matera's Avatar
    Join Date
    May 2006
    Location
    3 miles below poverty level
    Posts
    1,383
    Version
    IrfanView 4.44
    OS
    64-bit Linux Distribution
    CPU Cores
    4

    Default

    Hah! I should have thought of that! *slaps head*

    I was happy when M$ finally changed the user directory to something spaceless -- but why couldn't they have done more, or not started the "Program Files" nonsense in the first place? *rant*
    Its: Belongs to "It"
    It's: Shortened form of "It is"
    ---------------------
    Lose: Fail to keep
    Loose: Not tight

    ---------------------
    Plurals do not require apostrophes

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •