Results 1 to 3 of 3

Thread: Batch rename does not use leading '0'

  1. #1

    Talking Batch rename does not use leading '0'

    I like the 'Batch\Conversion Rename fuction, but it does not recognise '0' as a starting number in in the 'Starting counter' in the 'options' section, under 'Batch Rename Settings'.

    For example, I want to rename a batch starting with 04981, but it changes it to 4981, and drops the leading '0'.

    Thx for the wonderful product, I have been using it since I heard about it on Leo Laport's show in the old Tech TV days!

    -Joe

  2. #2
    Professional User Mij's Avatar
    Join Date
    Mar 2007
    Location
    Camberley, Surrey, UK
    Posts
    2,763
    Version
    IrfanView 4.51
    OS
    32-bit Win 10
    CPU Cores
    3

    Default

    I have never tried a number that big. I assume you did put 5 # signs in the pattern field?

  3. #3
    Multiple User ChuckE's Avatar
    Join Date
    Jul 2006
    Location
    Arizona
    Posts
    289
    Version
    IrfanView 4.37
    OS
    64-bit Win 7 Professional SP1
    CPU Cores
    8

    Default

    You got it Mij, it really all depends upon the number of place holders (the #'s) used. I just tried two tests
    1) Where I renamed 8 images starting with the name "image#####" and the counter at 1.
    The result was "image00001.jpg" through "image00008.jpg"

    Then, because I wondered if the OP was having a problem with the image name starting with only the count, with no words or characters as a prefix, so I then
    2) Renamed another 8 images with the name "#####" and the count at 1. The result was "00001.jpg" through "00008.jpg"
    I wish to die peacefully in my sleep, like my grandfather.
    Not like those passengers, in his car, when he drove over that cliff.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •