Results 1 to 9 of 9

Thread: Disabling mouse wheel

  1. #1
    IV Newbie
    Join Date
    Aug 2010
    Posts
    2

    Question Disabling mouse wheel

    I am constantly accidentally bumping my mouse wheel causing Irfanview to jump to a different photo when I don't want to. I want to disable the mouse-wheel and just use the arrow buttons to change photos but I can not find the setting in the Irfanview preference menu to disable the wheel. Can someone help me?

    Thanks

  2. #2
    Moderator Enterprise User Bhikkhu Pesala's Avatar
    Join Date
    May 2007
    Location
    East London
    Posts
    6,136
    OS
    64-bit Win 10
    CPU Cores
    1

    Default

    Properties, Browsing, and disable "Jump to next image."

  3. #3
    IV Newbie
    Join Date
    Aug 2010
    Posts
    2

    Default

    Quote Originally Posted by Bhikkhu Pesala View Post
    Properties, Browsing, and disable "Jump to next image."
    Thanks, but I have already tried this- and it doesn't make any difference rather this box is checked or not.

    I have notice some other controls in the properties don't seem to work either.

    I am using IV-4.25 and Win-7 if that makes any difference.
    Has anyone noticed any problems using IV with Win-7?

  4. #4
    Occasional User
    Join Date
    Nov 2007
    Location
    Virginia
    Posts
    124
    Version
    IrfanView 4.51
    OS
    64-bit Win 10
    CPU Cores
    4

    Default

    I can confirm that the recommended option doesn't solve the OP problem ... it only takes effect if vertical scroll bars are visible (as the dialog box says).

  5. #5
    IV Beginner
    Join Date
    Dec 2009
    Location
    UK
    Posts
    52
    Version
    IrfanView 4.51
    OS
    64-bit Win 7 Home Premium
    CPU Cores
    2

    Default

    Quote Originally Posted by zoreo View Post
    I am constantly accidentally bumping my mouse wheel causing Irfanview to jump to a different photo when I don't want to. I want to disable the mouse-wheel and just use the arrow buttons to change photos but I can not find the setting in the Irfanview preference menu to disable the wheel.
    I too desperately want to disable mouse scroll. Paradoxically, I have found it better to Properties, Browsing, and ENABLE "Jump to next image" because whenever I touch the wheel it is always going to jump, and if I have it enabled, I can at least scroll back to the first image. When it is disabled, as soon as IV displays an image so large the scroll bars appear, IV cannot scroll and gets stuck on that image.
    Last edited by Bhikkhu Pesala; 19.10.2019 at 07:04 PM. Reason: Fixed typo

  6. #6

    Default

    I don't understand how this isn't an option yet. It's the single most annoying thing about this program. I'm pretty sure people have been complaining about it since the very first day it was added 19 years ago...

    The only way to disable it is to disable directly browsing entirely ("View all"), which isn't good.

  7. #7
    Moderator Enterprise User Bhikkhu Pesala's Avatar
    Join Date
    May 2007
    Location
    East London
    Posts
    6,136
    OS
    64-bit Win 10
    CPU Cores
    1

    Default

    Quote Originally Posted by 18hornblowermedical View Post
    I don't understand how this isn't an option yet.
    Please see this feature request thread that was started in 2007. The request was forwarded by Mij in 2016, and was rejected by Irfan Skiljan.

  8. #8

    Default

    I don't get what the problem is. Even if you rest your index finger on the mouse wheel (bad practice) it must be very sensitive or the user very cack handed to, unwantedly, move it enough to scroll to the next image.

    With my current mouse, a recently purchased bog standard but proven reliable Dell design: 0XN967 the scroll wheel is much less mechanically 'notchy' than the much used 9 year old 0XN966 it replaced. Yet I still have no problem not accidentally scrolling to the next image when using IRFV.

    If this is a problem for some people I'd be looking at the mouse wheel scrolling sensitivity settings. More sophisticated mouses (mice?) might have alternative drivers or other software configuration setting options available too.

  9. #9
    Power User j7n's Avatar
    Join Date
    Jun 2006
    Location
    Cyberspace
    Posts
    542
    Version
    IrfanView 4.51
    OS
    32-bit Win Server 2003 SP1
    CPU Cores
    1

    Default

    I have a basic old Microsoft mouse. The wheel moves in mechanical notches or clicks. They are quite "soft", there is not much force to overcome, meaning that I can touch the wheel a few times lightly, and it will roll over. I don't need to move it much at a single touch. Maybe modern mice are more reliable or have sophisticated movement sensors.

    Once the mouse is worn or has accumulated dirt around the wheel below the surface (it is soft rubber), the notches disappear and the wheel moves quite easily from nudging the mouse body or resting the middle finger next to the wheel on the right mouse button.

    I had this "problem" before, but have since replaced the mouse with a new one of the same type and am bothered by this issue to a lesser extent.

    There are no applicable global system settings, and I don't see how they could help with a basic wheel. All they could do programmatically is maybe require 2 or 3 notches to be moved to register 1, which would make the wheel awkward to use normally.

    I feel that the effect of the wheel should be easily reversed by rotating it in the opposite direction if it was accidental. Most programs zoom with the wheel or operate a slider, which are reversible actions. This is not the case with IrfanView right now. If the new image is of a larger size, we can't return to the previous image by rotating the wheel backwards, and any processing on the previous image is lost.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •