Results 1 to 8 of 8

Thread: Selection gets "dropped" during move with mouse

  1. #1
    IV Amateur
    Join Date
    Apr 2007
    Posts
    14
    Version
    IrfanView 4.30
    OS
    32-bit Win XP Pro SP3
    CPU Cores
    4

    Default Selection gets "dropped" during move with mouse

    This has been happening for as long as I can recall - even with new v4.30

    When moving selection boxes the mouse "slips" off the selection and drops it. The faster the mouse motion the quicker the "drop".

    Very frustrating when trying to move a small selection cut from top of a tall document to the bottom. (yeah, I could just recreate the selection at the bottom, but it is a pain in the ** to have to note selection sizes and then recreate them)

    1. Make a selection with left mouse button - say 300px wide x 300px high
    2. Move mouse cursor over selection - cursor changes to zoom mag glass
    3. Right click on selection box - cursor changes to 4 arrow crosshair
    4. Start dragging selection down page - even very slowly. Crosshair starts slipping down inside selection until it reaches selection border, and then "drops" selection box.

    If the image is larger than the screen view (scrollbars showing), the image scrolls after the slip.

    It behaves just like a real world object being slid across a tabletop with a slippery finger - the friction of the object causes the finger to slip across the top of the object until finger is no longer on the object.

    ------
    WinXPsp3 / Intel Quadcore 9300, 4gig DDR2, 4.5 Tb HDs, 9800GTX Video, dual monitor - 23.5" flat and 21" crt.


    Addendum: This occurs using a corded Logitech MX-518 mouse, but also with my old Logitech MX700 wireless mouse.

    Also noted a new twist today while experimenting - zoomed in images behave differently.

    If image is zoomed in to say 200%, the mouse sometimes "slips off" the selection in THE OPPOSITE DIRECTION! ie: if dragging a selection down the page, the mouse cursor slips UP in the selection and then falls off the top of the selection (like the selection box is moving faster than the cursor instead of slower like the "friction on a tabletop" analogy above)

    Also, unlike my original description where mouse slips down off of selections in 1:1 viewed images, this weird behavior also includes slipping and dragging/scrolling the image at the same time - cursor slips to edge of selection area and then both drags the selection and scrolls the image while the cursor flickers from the crosshair to hand icon. If zoom is higher (say 500%) sometimes there is no selection move at all - immediate scrolling occurs.

    Also, at high zoom level, moving the mouse in fast jerks sometimes keeps the cursor in the selection, while carefully moving the mouse slowly causes it to slip off the selection (and usually the opposite side)

    Sorry, but I can't nail it down much more - depending on zoom level and mouse movement speed, IV does completely different things - all of which are bad unfortunately. I'm trying to generate some video to illustrate, but issues with capturing the cursor, encoding, and getting the problems to replicate reliably are occuring.
    Last edited by berserker; 27.06.2011 at 07:17 AM. Reason: Additional info

  2. #2
    Moderator
    Join Date
    Aug 2007
    Location
    Germany
    Posts
    855
    Version
    IrfanView 4.51
    OS
    64-bit Win 10
    CPU Cores
    8

    Default

    Hi,

    I tried to reproduce the behaviour you described. But if I move a selection to a border of a big picture (100% view, I see the scroll bars), I can just move the selection out of the visible area, but IrfanView doesn't scroll. But the cursor just slips out of the selection if I hit the window border.

    It doesn't matter if I zoom in or not.

    I don't know exaclty which bevaviour is expected or what Irfan had programed, so it is a little bit difficult to say if this is a bug or not.

    I tried this using Win 7 x64 and IV 4.30.

    Regards, Nils.

  3. #3
    IV Amateur
    Join Date
    Apr 2007
    Posts
    14
    Version
    IrfanView 4.30
    OS
    32-bit Win XP Pro SP3
    CPU Cores
    4

    Default

    Quote Originally Posted by derniwi View Post
    Hi,
    I tried to reproduce the behaviour you described. But if I move a selection to a border of a big picture (100% view, I see the scroll bars), I can just move the selection out of the visible area, but IrfanView doesn't scroll. But the cursor just slips out of the selection if I hit the window border.
    Definitely slips off the selection at borders and does not scroll - THAT I believe is by design.

    My problem is slipping off the selection area in the middle of the screen/image - not at the borders.

    Can you try it with a large image (1600px x 1600px), maybe with a narrow selection area (600px wide x 80px high), and maybe with a faster mouse drag speed? Also, try it when zoomed in 1000%.

    Also seems to maybe occur with more "complex" images - large, detailed, lots of colors - more than with a blank white large image. Maybe it's a "mouse event" dropping issue with high cpu and mem usage with the larger images. (but I have 4gig mem and a quadcore machine)

    Thanks.

  4. #4
    Moderator
    Join Date
    Aug 2007
    Location
    Germany
    Posts
    855
    Version
    IrfanView 4.51
    OS
    64-bit Win 10
    CPU Cores
    8

    Default

    Ok, I did the following:
    1. load a picture (4849x3233 pixels)
    2. zoom in to 1000%
    3. move the mouse fast and wild

    As a result the picture is sometimes scrolled and the mouse moves out of the selection, but the selection itself doesn't get lost, the mouse pointer is displayed as my standard pointer and not the move selection pointer. Also the selection will be moved if I mouve the mouse (the right mouse button is pressed all the time). So scorlling with pressed right mouse button is ok because the mouse point is out of the selection.

    And my computer should also have enough power and ram.

    I also see a problem with the selection if I move (the selection with) the mouse slowly when zoomed in: the selection doesn't get moved.
    Can someone check this?

  5. #5
    Professional User Mij's Avatar
    Join Date
    Mar 2007
    Location
    Camberley, Surrey, UK
    Posts
    2,763
    Version
    IrfanView 4.51
    OS
    32-bit Win 10
    CPU Cores
    3

    Default

    I cannot reproduce your problem when moving the mouse slowly, derniwi, whatever zoom ratio I set, but the original issue of the box being left behind when dragging a thin selection too rapidly is very obvious. After the cursor escapes from the selection, the zoomed image is then itself dragged instead of the box and that compounds the problem by leaving the box even further behind. Even this effect is inconsistent though. Usually the cursor changes from the 4-headed arrow to a hand when it has escaped from the box but sometimes it changes to a standard position arrow and then does not drag anything. Clearly different actions occur according to speed of code execution relative to mouse movement.

    The appearance is that the position of the cursor relative to the box is being continuously monitored and the function changed if the cursor is found to have moved outside of the box confines. I see no reason for that. After the program has established that the right mouse button click was made within the selection box and therefore that the desired function is to drag the box, the function does not need to change until the right button is released again.

    IMHO the erratic behaviour ought to be avoidable within the code and so it should be reported as a bug.

  6. #6
    IV Amateur
    Join Date
    Apr 2007
    Posts
    14
    Version
    IrfanView 4.30
    OS
    32-bit Win XP Pro SP3
    CPU Cores
    4

    Default

    Is this issue going to transition to confirmed, or is it going to fade away?

    Just ran into it again yesterday when trying to move a not very tall selection box down the page to paste a URL back into a browser screen shot - had to regrab selection a dozen times to get it halfway down the image.

  7. #7
    Moderator
    Join Date
    Aug 2007
    Location
    Germany
    Posts
    855
    Version
    IrfanView 4.51
    OS
    64-bit Win 10
    CPU Cores
    8

    Default

    Hi,

    I've forwarded this problem to Irfan.

    Regards
    Nils

  8. #8
    IV Amateur
    Join Date
    Apr 2007
    Posts
    14
    Version
    IrfanView 4.30
    OS
    32-bit Win XP Pro SP3
    CPU Cores
    4

    Default

    Quote Originally Posted by derniwi View Post
    Hi,

    I've forwarded this problem to Irfan.

    Regards
    Nils
    Great! Thanks Nils.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •