Results 1 to 10 of 10

Thread: V4.32: Gimp XCF support not in viewer

  1. #1
    IV Newbie
    Join Date
    Dec 2011
    Posts
    6
    OS
    32-bit Win Vista Home Premium SP2
    CPU Cores
    2

    Default V4.32: Gimp XCF support not in viewer

    Gimp .xcf opens in Irfanview (4.32) but doesn't show in Thumbnails viewer.

  2. #2
    Plugin Author
    Join Date
    Jun 2007
    Posts
    341
    OS
    Win 7 Professional SP1

    Default

    This should work. Maybe check if XCF has been added to all options.

  3. #3
    IV Newbie
    Join Date
    Dec 2011
    Posts
    6
    OS
    32-bit Win Vista Home Premium SP2
    CPU Cores
    2

    Default

    Thanks for your reply.
    I'm not sure I follow what you mean, "Maybe check if XCF has been added to all options"?

    I uninstalled and reinstalled Irfanview (iview432_setup.exe) and all plugins (irfanview_plugins_432_setup.exe). Tried opening a Gimp *.xcf file with the following error.

    Decode Error!
    Can't load plugin: "imxcf.dll"
    Please install or update plugins

    I rebooted and Irfanview will open a *.xcf but at the wrong size. eg., 1536x1024 file at 256x170. I have *.jpg and *.psd versions of the same file and they open properly so I don't think it's my view menu options (Shift+O) that are causing this. I checked file associations and *.xcf is not listed. The second problem is if I use the Thumbnail viewer *.xcf files do not show up.

    Windows Vista Home Premium SP2

  4. #4
    Plugin Author
    Join Date
    Jun 2007
    Posts
    341
    OS
    Win 7 Professional SP1

    Default

    Check that "XCF" ist part of the 'Settings/Extensions/Load custom file tpes' list. It is part of the default extensions but if you are reusing an existing ini file it will not be added automatically (same for "PDN" extension).

    Maybe this solves your size issue too. If height or width is 256 it may be that Irfanview asks the plugin to generate the thumbnail and not the composite image in full size.

  5. #5
    IV Newbie
    Join Date
    Dec 2011
    Posts
    6
    OS
    32-bit Win Vista Home Premium SP2
    CPU Cores
    2

    Default

    Here is a part of the list, |VOB|MPO|PDN|XCF|WEBP|WEBM|
    Is there a ini file I should edit or replace?

  6. #6
    Plugin Author
    Join Date
    Jun 2007
    Posts
    341
    OS
    Win 7 Professional SP1

    Default

    It will be saved to the default ini file. So after adding and activating of the list you should restart Irfanview.
    If this does not help then I do not know what to do else.

  7. #7
    IV Newbie
    Join Date
    Dec 2011
    Posts
    6
    OS
    32-bit Win Vista Home Premium SP2
    CPU Cores
    2

    Default

    I loaded default extensions, re-started Irfanview with the same result as above. Re-booted Vista, no change. The Thumbnail viewer will not show xcf files either. A few people I know at Gimp Chat forum have Irfanview, I will check there if anyone else is having issues. I will report back with any news.

    Thank you for your help and great work!

  8. #8
    IV Newbie
    Join Date
    Dec 2011
    Posts
    6
    OS
    32-bit Win Vista Home Premium SP2
    CPU Cores
    2

    Default

    I checked with a few people at Gimp Chat and they have no problems. I got it working, sort off. I open an xcf it loads small, I hit spacebar, backspace and all is well. I can live with that. Thanks again for your help.

  9. #9
    IV Newbie
    Join Date
    Dec 2011
    Posts
    6
    OS
    32-bit Win Vista Home Premium SP2
    CPU Cores
    2

    Default

    I did some experiments opening xcf files. If I drag and drop into Irfranview, the file opens OK. If I open an xcf from the Thumbnail view, the file opens OK. If I use File open in Irfranview, xcf file opens very small. If I uncheck "Preview active" in the File open dialog, xcf file opens properly.

    This was only a problem with *.xcf files, all other formats work normally (v4.32).
    Last edited by Odinbc; 21.12.2011 at 11:31 PM.

  10. #10
    Plugin Author
    Join Date
    Jun 2007
    Posts
    341
    OS
    Win 7 Professional SP1

    Default

    Quote Originally Posted by Odinbc View Post
    I did some experiments opening xcf files. If I drag and drop into Irfranview, the file opens OK. If I open an xcf from the Thumbnail view, the file opens OK. If I use File open in Irfranview, xcf file opens very small. If I uncheck "Preview active" in the File open dialog, xcf file opens properly.

    This was only a problem with *.xcf files, all other formats work normally (v4.32).
    Means thumbnail view is now working for you, fine.
    Maybe you should try to remove the current ini file and check if this helps for the remaining issue.

    Irfanview handles .xcf and .pdn as multipage format images, First page shows the composite and the other pages the layers. So this is a little bit special than other formats.

    As I told in an other thread: To show the transparency of composite or layers using a checkerboard background you have to set ini variables.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •