Announcement

Collapse
No announcement yet.

Plugin "Verlustfreie Rotation" spinnt

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Plugin "Verlustfreie Rotation" spinnt

    Ich beobachte das schon länger...:
    Wenn ich ein .jpg Bild um 90° drehen will, wird es fälschlicherweise um 180° gedreht...
    Ich muß dann nochmal um 270° drehen, damit das Bild aufrecht seht...
    Ich kann aber auch erst um 270° drehen und hinterher um 90° damit das Bild richtig orientiert ist.

    Die einfache Rotation um 90° funktioniert bei mir einfach nicht.

    Hab dafür eine etwas schnellere Abhilfe gefunden: Für die 90° Rechtsdrehung stelle ich 180° ein und mache das 2x hintereinander, dann steht das Bild auch so wie ich es will...

    Spinne ich oder spinnt das Plugin...? Mache ich etwas falsch oder was ist da los...? Oder ist das ein Irfan-Problem?

    Gruß
    Wolfgang

    #2
    Do you have Autorotate based on Exif info enabled in Settings, JPG/PCD/GIF ?

    If that's not it, attach a sample image that causes this issue. Lossless rotation works as expected for me on regular JPG images without Exif data.
    Before you post ... Edit your profile • IrfanView 4.58 • Windows 10 Home

    Irfan PaintIrfan View HelpIrfanPaint HelpRiot.dllMore SkinsFastStone CaptureUploads

    Comment


      #3
      Originally posted by Bhikkhu Pesala View Post
      Do you have Autorotate based on Exif info enabled in Settings, JPG/PCD/GIF ?
      No.

      If that's not it, attach a sample image that causes this issue. Lossless rotation works as expected for me on regular JPG images without Exif data.
      I found that after optimization (Shift+U) seems as if Exif orientation Info is lost. These pictures generate the effect descibed. Here a sample:

      Click image for larger version

Name:	IMG_4033.JPG
Views:	1
Size:	1.23 MB
ID:	83139

      The picture is shown left rotated in Irfanview. (I switched off automatic Exif orientation also in Irfanview.) So I need to rotate it right (90°) with lossless orientation plugin, but it doesn't, it rotates 180° as described above... So I need another orintation step with 270°.

      B.T.W.: I wrote the original post in German, "Verlustfreie Rotation" spinnt . "Spinnt" has nothing to do with the englisch term "spin"... It just means "Lossless Orientation behaves crazy"

      @Admin: Is it better to write in english or in german?

      Comment


        #4
        This is the German forum. You should write in German here, but I don't know German. If you can wait, someone will reply in German. I replied to speed up the process.

        See this thread on lossless crop operations.

        If you disable autorotate it won't need rotating right.

        Use these settings to clean up the Exif data and thumbnail.

        Click image for larger version

Name:	Fix Thumbnail.png
Views:	1
Size:	17.2 KB
ID:	83140Click image for larger version

Name:	Fixed.JPG
Views:	1
Size:	1.23 MB
ID:	83141
        Last edited by Bhikkhu Pesala; 03.07.2018, 01:27 PM.
        Before you post ... Edit your profile • IrfanView 4.58 • Windows 10 Home

        Irfan PaintIrfan View HelpIrfanPaint HelpRiot.dllMore SkinsFastStone CaptureUploads

        Comment


          #5
          Ich habe auch dieses Problem seit Jahren. Es hat auch mehrere IrfanView -Updates überlebt.
          Unregelmäßig und ohne erkennbaren Anlass verweigert "Verlustfreie Rotation" im ersten Versuch die Arbeit. Ich stelle z.B. 90 Grad ein, klicke auf Starten und es passiert nichts.
          Im zweiten Anlauf geht es dann. Oder es kommt vor, dass ich 270 Grad einstelle, das Bild aber nur 180 Grad gedreht wird.
          Das passiert immer dann, wenn ich Bilder bearbeite.
          Wenn mich dann das Problem so nervt, dass ich der Sache mit Versuchen auf den Grund gehen möchte, ist der Fehler weg. So eine Art Vorführeffekt.
          Kann jemand das Problem bestätigen? ... oder sollte ich mal einen Termin mit dem Psychiater ausmachen?

          Ich benutze Win 10 Prof 64 in der aktuellen Version mit IrfanView 4.54 32 Bit.
          Last edited by Fr8train; 05.08.2020, 07:11 PM.

          Comment


            #6
            Die Verwirrung um dieses Thema ist nicht neu.

            Ich selbst hatte bislang nicht das Bedürfnis ein Bild zu drehen. Theoretisch kann m.W. der Upload eines uneditierten Fotos auf eine Webseite/Forum Probleme machen, wenn die Webseite beim Display das Exif orientation tag nicht berücksichtigt.

            Da ich Bilder vor dem hochladen stets editiere (Größe,Schärfen, ...) kommt das bei mir aber nie vor.

            Meine Einstellungen sind 'Autororate' und beim Speichern 'setze Exif orientation tag'

            Mit dieser Konfiguration habe zumindest ich ich das Problem nicht.

            Click image for larger version

Name:	iv_save_orient.png
Views:	1
Size:	43.3 KB
ID:	83493

            Click image for larger version

Name:	iv_save_orient2.png
Views:	1
Size:	22.9 KB
ID:	83494

            currently running 4.56 / 32 bit

            Comment


              #7
              Originally posted by jazzman View Post
              Die Verwirrung um dieses Thema ist nicht neu.

              Ich selbst hatte bislang nicht das Bedürfnis ein Bild zu drehen. Theoretisch kann m.W. der Upload eines uneditierten Fotos auf eine Webseite/Forum Probleme machen, wenn die Webseite beim Display das Exif orientation tag nicht berücksichtigt.

              Da ich Bilder vor dem hochladen stets editiere (Größe,Schärfen, ...) kommt das bei mir aber nie vor.

              Meine Einstellungen sind 'Autororate' und beim Speichern 'setze Exif orientation tag'

              Mit dieser Konfiguration habe zumindest ich ich das Problem nicht.

              [ATTACH=CONFIG]5923[/ATTACH]

              [ATTACH=CONFIG]5924[/ATTACH]
              Es gibt viele Bilder, die keine EXIF-Info besitzen. Das Problem tritt eigentlich nur da auf bzw. beim Mix verschiedener Einstellungen... Die richtige hab ich auch noch nicht gefunden.

              Reset Exif orientation tag bedeutet Zurücksetzen des Orientierungs- Tags
              Beim Laden drehen sagt nur aus, daß die Anzeige entsprechend der EXIF-Info am Bildschirm angezeigt wird.

              Wiso hast du eigentlich die englische Benutzeroberfläche...? Oder bist du native speaker?

              Gruß

              Comment


                #8
                Originally posted by Mausebär View Post
                ...
                Reset Exif orientation tag bedeutet Zurücksetzen des Orientierungs- Tags
                Was es aber tatsächlich tut ist den tag entsprechend der aktuellen Anzeige zu setzen, also nicht auf einen früheren Wert oder Standardwert zurücksetzen, sondern neu setzen.

                Beim Laden drehen sagt nur aus, daß die Anzeige entsprechend der EXIF-Info am Bildschirm angezeigt wird.
                ja, es wird nur für die Anzeige gedreht, aber nicht gespeichert.

                Wiso hast du eigentlich die englische Benutzeroberfläche...? Oder bist du native speaker?
                Zum einen ist Englisch meine Lieblingssprache. Zum anderen sind Anwendungen (IrfanView ist hier eine rühmliche Ausnahme) oft miserabel übersetzt, sodass man oft nicht weiß was gemeint ist. -Da stelle ich meinen Komposter doch möglichst einheitlich auf Englisch ein.

                Grüße
                Last edited by jazzman; 06.08.2020, 04:30 PM.

                currently running 4.56 / 32 bit

                Comment


                  #9
                  Hier ist noch ein sehr interessanter Beitrag zum Thema von Mij, der sich intensiv mit dem Problem beschäftigt hat: https://irfanview-forum.de/showthrea...ull=1#post8252

                  currently running 4.56 / 32 bit

                  Comment


                    #10
                    Ich habe da Problem mal in einem Screen-Recording Video eingefangen. Falsch rotiert wird nur beim ersten Mal. Nachfolgende Rotationen werden korrekt ausgeführt.
                    http://web73.webclient1.de/vid/Rotation_Problem.mp4

                    Comment

                    Working...
                    X